Triway Cup '18 Summer F - Forget Me Not

View as PDF

Submit solution

Points: 5
Time limit: 2.0s
Memory limit: 256M

Author:
Problem type

The black foxen are the arch enemies of Tushan: they corrupt the love of reincarnated soulmates by absorbing their memories. This allows the black foxen to steal their pledge of love and the resulting spirit power.

The black foxen would like to prioritize a victim's memories, starting with the most important one. They have converted each memory to an integer, with up to 1 million digits (this will not fit in int data type). For this problem, the black foxen have hired you to compare two memories and print the one which is higher.

Given 2 non-negative integers S and T on different lines, where both S and T are less than 10^{100\,000}. The number may contain leading zeros. If S is larger than T output S, if T is larger than S output T, otherwise output E.

Sample Input

123456765434567652143783748374938274932798478329749328
0432874832787589275324893729562839478

Sample Output

S

Comments


  • -3
    showme  commented on Sept. 18, 2020, 3:00 a.m. edited

    Umm... Why is it that it says that I will get 5 points but I only got 2?


  • -2
    HS  commented on Oct. 20, 2018, 3:10 a.m. edit 2

    How do you convert S and T into an integer?

    Is there a command that inputs integers with up to 1 million digits?

    Nevermind-fixed


    • -4
      AutumnBreeze_qwq  commented on Oct. 5, 2019, 1:17 p.m.

      s=int(input()) t=int(input())


  • -4
    GD_FrostByte  commented on Sept. 25, 2018, 7:55 p.m. edit 4

    of course number 4 is infinity and infinity

    i finally finished

    i used python

    im so rusty at python


    • 11
      aeternalis1  commented on Sept. 25, 2018, 8:22 p.m. edited

      The constraints on this problem state the numbers in the input can be up to a hundred thousand digits long. Find a different way to store them, because they will certainly not fit in an int, long or float. Or a double, which I see you attempted to use after I commented.


      • 2
        HS  commented on Oct. 20, 2018, 3:23 a.m.

        I'm using python 3 and my code worked by inputing an integer normally with int(input()). It seems that the test cases do fit in an int.

        Am i wrong?


        • 4
          kingW3  commented on Oct. 20, 2018, 9:06 a.m.

          Python int is a big int, in most languages though this isn't the case (c++, c, java, etc.)


  • -3
    GD_FrostByte  commented on Sept. 23, 2018, 10:01 p.m.

    y am i getting IRs


    • 5
      Relativity  commented on Sept. 23, 2018, 11:45 p.m.

      The number can be bigger than an int or a long